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Certification Test Goals
This module sets out essential concepts and skills relating to the 
ability to understand key web publishing concepts and to create, 
upload and maintain a static web site.

Successful candidates will be able to:
•	 Understand key web concepts and terms.
•	 Know about the basic principles of HTML and use common HTML 

mark-up tags to modify the layout of a web page.
•	 Use a web authoring application to design and format web pages, 

format text, and work with hyperlinks and tables.
•	 Recognise and use common web image formats and create forms 

in a web page.
•	 Understand and use cascading style sheets. 
•	 Prepare web pages for publishing to a web server.

General 
Open the file menu 	 Alt+F 
New file 	 Ctrl+N 
Open a file 	 Ctrl+O
Close the current file 	 Ctrl+W

Preview Page
Browse Page 	 F5

1.1		 Key Terms
1.1.1		 Understand that the Internet supports a 

range of services like:
•		 The World Wide Web (WWW) 
•		 File transfer
•		 Email
•	 Instant messaging (IM)

1.1.2		 Understand the term client/server.
•		 In a client/server network, the server 

stores data which can be requested and 
used by the client.

1.1.2		 Understand the functionality and 
relationship between the browser, web 
server.

•	 A web server stores and delivers web 
documents.

•	 A web browser displays pages sent by a 
web server.

1.1.3		 Understand the terms domain, Uniform 
Resource Locator (URL), hyperlink, web 
hosting, search engine.

•	 Domain - Identifies ownership of a web 
address 

•	 Uniform Resource Locator (URL) - A 
website address that is unique for every 
website

•	 Hyperlink - A graphic or text with an 
embedded cross reference that connects 
to a web page, or portion of a web page

•		 Web hosting - A service which allocates 
space for websites on computer servers

•	 Search engine - Software designed to 
search for information on the World Wide 
Web

1.1.4		 Understand the use of primary protocols:
•	 Transmission Control Protocol/Internet 

Protocol (TCP/IP) - The protocol suite 
upon which the Internet is based

•		 Hypertext Transfer Protocol (HTTP) - 
Used to request and transport World 
Wide Web pages across the Internet

•	 File Transfer Protocol (FTP) - Used to 
transfer files from one computer to 
another over a TCP/IP network

1.2		 Web Publishing
1.2.1		 Identify the main advantages of having a 

website:
•	 Access to a global audience 
•	 Ease of updating
•	 Audience interactivity 
•		 Cost benefits

1.2.2		 Understand the process of getting a website 
online like:

•	 Registering a domain - To obtain exclusive 
use of a unique domain for a period of time

•		 Choosing a web hosting service - To store 
and display your website on computer servers 
that are connected to the Internet

1.2.3		 Recognize search engine optimization 
techniques like:

•		 Including relevant meta data  
•		 Including a site map and website links 
•	 Registering with a search engine

1.2.4		 Recognize factors that impact on web page 
download speed: audio, video, graphical 
objects, animation content, file compression.

•	 High quality Audio
•	 High definition Video
•		 Too many graphical objects on a web page 
•		 Animation Content - Too much on a web page 

can decrease web page download speed
•	 	File compression - to decrease file size and 

decrease web page download speed
1.2.5		 Recognize appropriate audio, video, graphical 

file formats to optimize web page download 
speed.

•	 Audio - MIDI, MP3
•	 Video - Flash Video .flv files
•	 Graphical file formats - jpeg, gif

1.3		 Legal Issues
1.3.1		 Understand the term copyright and its 

implications for text, images, audio, video 
available on websites.

•	 Copyright is a legal way to protect the rights 
of ownership of a website and any text, audio, 
images and video it may contain.

1.3.2		 Understand that website content is subject to 
the laws of the country in which it is hosted.

•	 	Website content is subject to the laws of the 
country in which it is hosted rather than the 
country in which it was originally created.

2.1		 Fundamentals of HTML
2.1.1		 Understand the term Hypertext Markup 

Language (HTML).
•	 Hypertext Markup Language (HTML) is a 

tag based notation language used to format 
documents on the world wide web.

2.1.2		 Understand the role of the W3C consortium in 
developing HTML recommendations.

•	 World Wide Web Consortium (W3C) 
is a standards body that gives 
recommendations for the development of 
open web standards, HTML.

2.1.2		 Understand the benefits these 
recommendations offer like:

•	 Interoperability of websites across 
browsers - Allows the viewing of web 
pages across a range of devices and 
browsers

•	 	Enhanced accessibility - Improves search 
result rankings, reduces maintenance 
costs, and increases audience reach

•	 	Consistent document type declarations - 
Give web pages a consistent look

2.2		 Using HTML
2.2.1		 Use the browser to view web page source 

code.
•		 Click to open Internet Explorer.
•		 Browse to the web page you want to 

view. Click the View menu.
•	 Click Source.

2.2.2		 Use markup tags to structure a web page 	
layout: <html>, <head>, <title>, <body>.

•	 Open a text editor and enter the following 
tags:
<html>
<head>
<title> This is a title</title>
</head>
<body> This is body text. </body>
</html>

2.2.3		 Use markup tags to develop the layout of 
a web page: <h1>, <h2>, <p>, <br />, <a 
href>, <img />.

•	 Open a text editor and enter the following 
tags:
<html>
<head>
<title> This is a title</title>
</head>
<h1>This is a heading</h1>
<h2>This is a smaller heading</h2>
<br />creates a single line break in a 
block of text
<p>This is a paragraph.</p>
<a href=”http://www.ecdl.org”>This is a 
link</a>
<img src=”school.jpg” width=”104” 
height=”142” />
</html>
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Menu Bar

Page Tab

Page Area

Status Bar

Composition Toolbar

Site Manager

Format Toolbars

Edit mode toolbar

Rulers

Editing 
Open the edit menu 	 Alt+E
Cut 	 Ctrl+X 
Copy 	 Ctrl+C 
Paste 	 Ctrl+V

Formatting 
Bold 	 Ctrl+B 
Italics 	 Ctrl+I
Underline 	 Ctrl+U



3.1		 Design
3.1.1		 Recognize planning and design techniques 

like:
•	 Evaluating the needs of the target 

audience 
•	 Creating storyboards
•	 Organising the site structure 
•		 Creating a page layout template 
•	 Deciding on a navigation scheme

3.1.2		 Recognize good practice in font selection. 
Using sans serif fonts like: Arial, Courier, 
Helvetica.

•	 A sans serif font is suitable for a web 
page because it can be easily viewed in 
both high and low resolution.

3.2		 Using the Application
3.2.1		 Open a web authoring application.

•	 Click the Start button. 
•	 Select All Programs.
•		 Click KompoZer.

3.2.1		 Close a web authoring application.
•	 On the File menu, click Exit.

3.2.1		 Open web pages.
•	 On the File menu, click Open File.
•	 Select web pages(s) to open and click 

Open.
3.2.1	 	Close web pages.

•		 On the File menu, click Close or Close 
All.

3.2.2		 Create a new web page.
•	 On the File menu, click New.
•	 Click A blank document.
•		 Click Create.

3.2.2		 Create, save a new website to a location on 
a drive.

•		 On the Edit menu, click Publishing Site 
Settings.

•	 Enter the local site folder details. 
•		 Enter site information. 
•		 Click OK.

3.2.2		 Save a new web page to a location on a 
drive.

•	 On the File menu, click Save.
•	 Enter a page title.
•	 Click OK.
•	 Create a file name and navigate to the 

location required.
•	 Click Save as type and click HTML Files. 
•		 Click Save.

3.2.3		 Create a new web page based on an 
available template.

•		 On the File menu, click New.
•	 Click A new document based on a 

template.
•	 Select a site that contains the template or 

choose a local template. 
•		 Select a template.
•	 Click Create.

3.2.3		 Save a new web page based on an 
available template.

•		 On the File menu, click Save.
•	 Enter a page title.
•		 Click OK.
•	 Create a file name and navigate to the 

location required.
•	 Click Save as type and select HTML 

templates. 
•	 Click Save.

3.2.4		 Add, edit a descriptive page title. 

•	 On the Format menu, click Page Title and 
Properties.

•	 Enter a new page title in the Title box.
•		 Click OK.

3.5.1		 Set paragraph properties: indentation.
•	 Select the paragraph to indent. 
•	 On the Format menu, click Increase 

Indent or Decrease Indent.
3.5.2		 Insert, remove paragraph break.

•	 To insert position the cursor to force a 
line break. 

•		 Click the Format menu.
•		 Select Paragraph and click Paragraph.
•		 To remove click at the beginning of the 

paragraph and press the Backspace key.
3.5.2		 Insert, remove line break.

•		 To insert press the Return key.
•	 To remove click at the beginning of the 

line break and press the Backspace key.
3.5.3		 Create a single-level ordered numbered list.

•	 Select the text to list. 
•		 On the Format menu, select List and click 

Numbered.
3.5.3		 Modify a single-level ordered numbered 

list.
•	 Click the list text to modify. 
•		 On the Format menu, select List and click 

List Properties.
3.5.3		 Create an unordered bulleted list.

•	 Click the text to list.
•	 On the Format menu, select List and click 

Bulleted.
3.5.3		 Modify an unordered bulleted list.

•	 Click the list text to modify.
•	 On the Format menu, select List and click 

List Properties.
3.6	 Page Formatting
3.6.1		 Set page margins: top, bottom, left, right.

•	 On the File menu, click Page Setup.
•		 On the Margins & Header/Footer tab, 

enter a left, right, top, bottom, margin. 
•		 Click OK.

3.6.2		 Add, modify a page background color.
•		 On the Format menu, click Page Colors 

and Background. 
•	 Check the Use custom colors checkbox.
•	 Click the Background colour box. 
•	 Select a colour from the colour picker.
•	 Click OK.

3.6.2		 Remove a page background color.
•	 On the Format menu, click Page Colors 

and Background. 
•	 Check the Use custom colors checkbox.
•		 Click the Background color box. 
•	 Click the Transparent checkbox.
•		 Click OK.

3.6.2		 Add, modify a background image.
•	 On the Format menu, click Page Colors 

and Background. 
•	 Click the Choose File icon beside the 

Background Image dialog box.
•	 Navigate to the image required and select 

the image. 
•		 Click Open and click OK.

3.6.2		 Remove a background image.
•	 On the Format menu, click Page Colors 

and Background. 
•	 Select the text in the Background Image 

dialog box. 
•	 Press the Delete key.
•	 Click OK.

3.6.3		 Change a page hyperlink colour: visited, 
active, unvisited.

•	 On the Format menu, click Page Colors 
and Background. 

•		 Check the Use custom colors checkbox.
•	 Click the appropriate links colour picker 

and click a color.
•	 Click OK twice.

3.2.5		 Change between source code and design view.
•	 Click the Source button on the Edit mode 

toolbar to show the source code.
•		 Click the Design button on the Edit mode 

toolbar to show the design view.
3.3		 Enhancing Productivity
3.3.1		 Set basic options/ preferences in the 

application: default preview browser.

•		 On the Tools menu, click Preferences.
•	 Click Applications in the category box. 
•		 Click use system default or use custom 

application to browse for a specific browser. 
•	 Click OK.

3.3.1		 Set basic options/ preferences in the 
application: default document type, encoding.

•	 On the Tools menu, click Preferences.
•		 Click Advanced in the category box. 
•	 Check the markup Language and DTD 

(document type definition) checkbox required.
•	 Click New Page Settings in the category box. 
•		 Click Choose a charset and click the default 

encoding required.
•		 Click OK twice.

3.3.1		 Set basic options/ preferences in the 
application: fonts.

•		 On the Tools menu, click Preferences.
•		 Click Fonts in the category box. 
•		 Click an encoding type from the Fonts for list. 
•		 Click a font typeface and size.
•		 Proportional font - Used to display normal 

text 
•		 Click OK.

3.3.2		 Use available Help functions.
•		 On the Help menu, click Help Contents.

3.4		 Text Input and Formatting
3.4.1		 Insert text.

•		 Enter text into the design page area.
3.4.1		 Edit text.

•	 Select the text and edit as required.
3.4.1		 Delete text.

•		 Select the text to delete. 
•		 Press the Delete key.

3.4.2		 Understand relative font size.
•		 Makes websites more accessible and 

readable 
•	 Can be set relative to surrounding elements 
•		 Allows a user to change the text size in 

browsers
3.4.2		 Use relative font size.

•	 Select the text to format.
•		 On the Format menu, select size.
•		 Click a relative size, for example, medium.

3.4.3		 Apply text formatting: bold, italic.
•		 Select the text to format.
•	 To embolden the text, on the Format menu, 

select Text Style and click Bold.
•		 To italicize the text, on the Format menu, 

select Text Style and click Italic.
3.4.3		 Apply text formatting: font type.

•	 Select the text to format. 
•		 On the Format menu, select Font. 
•		 Click on a font.

3.4.3		 Apply text formatting: colour.
•	 Select the text to colour. 
•	 On the Format menu, click Text Color and 

select a colour. 
•		 Click OK.

3.5	 Paragraph Formatting
3.5.1		 Set paragraph properties: alignment.

•		 Select the paragraph to align. 
•	 On the Format menu, select Align.
•		 Click Left, Center, Right, Justify.

3		 Web Authoring



3.7		 Hyperlinks
3.7.1		 Understand the terms absolute and relative 

hyperlinks.
•	 Absolute hyperlinks - used when linking 

to pages outside of the current site that 
have a different domain name

•	 Relative hyperlinks - addresses that are 
relative to the current domain or location

3.7.2		 Insert a hyperlink: text, image.

•	 Click in the web page where the link 
should appear. 

•	 On the Insert menu, click Link.
•	 Enter the link text in the Link Text box.
•	 Click in the Link Location box and enter 

the name of the file to link to or click the 
Choose File icon to browse for a file.

•		 Click the relevant box if The above is an 
email address or the URL is relative to 
page location.

•		 Click in the Target box and enter or select 
the name of the window in which the file 
should open.

•		 Click OK.
3.7.2		 Edit a hyperlink: text, image.

•	 Select the hyperlink to edit. 
•	 On the Format menu, click Link 

Properties.
•		 Enter the new file or URL details. 
•		 Click OK.

3.7.2		 Remove a hyperlink: text, image.
•	 Select the hyperlink to remove. 
•	 On the Format menu, click Link 

Properties.
•	 Select the text in the Link Location box.
•	 Press the Delete key.
•	 Click OK.

3.7.3		 Insert, an e-mail hyperlink: text.
•	 Select where the link should appear in the 

web page. 
•	 On the Insert menu, click Link.
•	 Enter the link text in the Link Text box.
•		 Enter the name of the file to link to in the 

Link Location box or click the Choose 
File icon to browse for a file.

•		 Check the The above is an email address 
checkbox.

•	 Click OK.
3.7.3		 Insert, an e-mail hyperlink: image.

•	 Click in the web page where the link 
should appear. 

•	 On the Insert menu, click Image.
•	 Enter the location of the image file in the 

Image Location box or click the Choose 
File icon to browse for a file.

•	 On the Link tab, enter the name of the file 
to link to or click the Choose File icon to 
browse for a file.

•	 Click the The above is an email address 
box.

•	 Click OK.
3.7.3		 Edit an e-mail hyperlink: text.

•	 Select the link.
•	 On the Insert menu, click Link.
•		 In the Link Location box, edit the e-mail 

address. 
•	 Click OK.

3.7.3		 Edit an e-mail hyperlink: image.
•		 Select the link.
•	 On the Insert menu, click Image.
•	 On the Link tab, edit the e-mail address. 
•	 Click OK.

3.7.3		 Remove an e-mail hyperlink: text.
•	 Click on the hyperlink to remove. 
•	 On the Format menu, click Link 

Properties.
•		 Select the text in the Link Location box.
•		 Press the Delete key.
•		 Click OK.

3.8.7		 Modify table border width, cell padding, cell 
spacing.

•	 Select the table. 
•		 On the Table menu, click Table 

Properties.
•	 Enter a value in the Border box. 
•		 Enter a value in the Spacing box.
•	 Enter a value in the Padding box.
•	 Click Apply. 
•	 Click OK.

3.8.8		 Change background colour of cells, entire 
table.

•	 Select the cell, cell(s) or table. 
•		 On the Table menu, click Table or Cell 

Background Color.
•		 Click the Background for Table or Cell(s) 

box.
•		 Click the colour required.
•		 Click OK.

3.8.8		 Change background graphic, image of 
cells, entire table.

•	 On the View menu, click HTML Tags.
•	 Click the tag for the table (or cell) while 

pressing the Ctrl key.
•		 On the status bar right-click on the 

highlighted tag.
•	 Click Inline Styles and click the 

Background tab.
•	 Click the Choose file button and click the 

image required. 
•		 Click the tiling and/or position properties 

as required.
•		 Click OK.

3.8.9		 Add a table background graphic, image.
•	 On the View menu, click HTML Tags.
•		 Click the tag for the table while pressing 

the Ctrl key.
•	 On the status bar right-click on the 

highlighted tag.
•	 Click Inline Styles and click the 

Background tab.
•	 Click the Choose file button and click the 

image required. 
•	 Click the tiling and/or position properties 

as required.
•	 Click OK.

3.8.9		 Remove a table background graphic, 
image.

•	 On the View menu, click HTML Tags.
•	 Click the tag for the table while pressing 

the Ctrl key.
•		 On the status bar right-click on the 

highlighted tag.
•	 Click Inline Styles and click the 

Background tab.
•	 Click the existing image location. 
•	 Press the Delete key.
•		 Click OK.

4.1		 Graphical Objects
4.1.1		 Add an image on a web page.

•	 On the Insert menu, click Image.
•		 Select the image using the Choose file 

button. 
•	 Click OK.

4.1.1		 Remove an image on a web page.
•		 Select the image. 
•		 Press the Delete key.

4.1.2		 Set, modify attributes of an image: size, 
border, alignment, alternative text.

•		 Select the image.
•		 On the Format menu, click Image 

Properties.
•	 On the Location tab, enter the image 

description in the Alternate text box.
•		 On the Dimensions tab, enter the image 

width and height in the Custom Size box.
•		 On the Appearance tab, and enter the 

width in the Solid Border box.
•		 Click the image wrap required from the 

Align Text to Image drop-down list.
•		 Click OK.

4.2	 Forms
4.2.1		 Insert a form on a web page.

•		 Select the location required to insert the 
form.

•		 On the Insert menu, select Form and click 
Define Form.

•	 Enter the name required for the form in 
the Form Name box

•		 Enter the URL in the Action URL box.

3.7.4		 Remove an e-mail hyperlink: image.
•	 Click on the image hyperlink to remove. 
•		 On the Format menu, click Image and Link 

Properties.
•		 On the Link tab, select the e-mail address 

text. 
•	 Press the Delete key.
•		 Click OK.

3.7.4		 Define hyperlink target: same window, new 
window.

•		 On the Insert menu, click Link.
•		 Check the Link is to be opened checkbox.
•	 Click the drop-down list to click an option.
•		 Click OK.

3.7.5		 Set an anchor.
•	 Click in front of the first letter of the word to 

be anchored.
•	 On the Insert menu, click Named Anchor.
•		 Enter a name in the Anchor Name box.
•		 Click OK.

3.7.5		 Insert a link to an anchor.
•		 Select the text to be linked.
•		 On the Insert menu, click Link.
•		 Click the anchor required in the Link Location 

drop-down list. 
•		 Click OK.

3.8	 Tables
3.8.1		 Insert a table.

•		 Select the position in the page where the 
table should appear. 

•		 On the Insert menu, click Table.
•	 In the Table dialog enter settings as required.

3.8.1		 Delete a table.
•		 Select the table.
•		 On the Table menu, select Delete and click 

Table.
3.8.2		 Insert a table caption.

•		 Select the table.
•		 On the Table menu, click Table Properties.
•	 Click the option required from the Caption 

drop-down list. 
•		 Click Apply. 
•	 Click OK.
•	 Enter the caption text in the caption row.

3.8.2		 Edit a table caption.
•		 Select the table caption and edit the text.

3.8.3		 Align a table: left, centre, right.
•		 Select the table. 
•		 On the Table menu, click Table Properties.
•		 Click Left, Center, Right from the Table 

Alignment drop-down list.
•		 Click Apply. 
•		 Click OK.

3.8.4		 Insert rows.
•	 Click in a cell above/below the row to insert. 
•		 On the Table menu, select Insert.
•		 Click Row Above or Row Below.

3.8.4		 Insert columns.
•		 Select a cell to the left/right of the column to 

insert. 
•	 On the Table menu, select Insert.
•		 Click Column Before or Column After.

3.8.4		 Delete rows and columns.
•	 Select a cell within the row or column to 

delete. 
•	 On the Table menu, select Delete.
•	 Click Row(s) or Column(s).

3.8.5		 Modify column width.
•		 Click any cell within the table. 
•	 Drag the ruler above the table of the column 

to change.
3.8.5		 Modify row height.

•	 Click any cell within the table. 
•		 Drag the ruler to the left of the table of the 

row to change.
3.8.6		 Merge cells.

•	 Select the cells to merge. 
•	 On the Table menu, click Join Selected Cells. 

3.8.6		 Split cells.
•		 Click any cell.
•		 On the Table menu, click Split Cell. 

4		 Using Objects
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•		 Click on the Method drop-down list to 
select the method to transmit the form 
data to the server.

•		 Click OK.
4.2.2		 Add single-line, multi-line text fields.

•	 On the Insert menu, select Form and click 
Form Field.

•		 To add a single-line text field, click the 
Field Type drop-down list and select Text.

•		 Enter a Field Name and Initial Value.
•		 Click OK.
•		 To add a multi-line text field, click the 

Insert menu, select Form and select Text 
Area.

•	 Enter a Field Name and enter a value for 
Rows and Columns.

• Click OK.
4.2.2		 Remove single-line, multi-line text fields.

•	 Select the field to remove and press the 
Delete key.

4.2.3		 Add form fields: drop-down, check box, 
radio button.

•	 On the Insert menu, select Form.
•		 To add a drop-down field, click Selection 

List. 
•	 To add a check box field, select Form 

Field and click Check Box.
•		 To add a radio button field, select Form 

Field and click Radio Button.
•		 Enter the field settings required.
•		 Click OK.

4.2.3		 Remove form fields: drop-down, check 
box, radio button.

•		 Select the field to remove and press the 
Delete key.

4.2.4		 Set, modify form field properties: text field.
•	 Double-click on the text field and set, 

modify the Form Field properties.
• 		Field Name - Enter the name for the field 
•	 	Initial Value - Enter default text or value
• 		Tab Index - Enter the position in the tab 

order for the field 
•	 Access Key - Enter a shortcut key that 

will take a user to that form field 
•	 	Field Size - Enter the maximum number 

of characters that can be displayed in the 
field 

• 		Max Length - Enter the maximum number 
of characters that can be entered in a text 
field 

•		 Click OK.
4.2.4		 Set, modify form field properties: drop-

down.
•		 Select the drop-down list to modify. 
•		 On the Format menu, click Selection List 

Properties to set, modify properties.
•	 List Name - Enter a unique name
• 		Height - Enter the number of items 

displayed in list 
•	 Tab Index - Enter the position in the tab 

order for the field 
• 		Add Option - Click Add Option to add 

items in the menu
•		 Select a list option to Remove, Move Up 

or Move Down.
4.2.4		 Set, modify form field properties: check 

box.
•	 Select the check box to modify.
•		 On the Format menu, click Form Field 

Properties to set, modify properties.
•	 Field Name - Enter the name for the field 
•	 	Field Value - Enter default value
•	 	Initially Checked - Select to have 

checked or unchecked
• 		Tab Index - Enter the position in the tab 

order for the field 
•	 Access Key - Enter a shortcut key that 

will take a user to that form field 
4.2.4		 Set, modify form field properties: radio 

button.
•		 Select the radio button to modify.
•		 On the Format menu, click Form Field 

Properties to set, modify properties.
• 		Group Name - Enter the name for the 

field group
• 		Field Value - Enter default value
•	 	Initially Selected - Select to have selected 

or unselected
• 		Tab Index - Enter the position in the tab 

order for the field 
• 		Access Key - Enter a shortcut key that 

will take a user to that form field 

5.2.2		 Create CSS rules: background.
•	 On the Tools menu, click CSS Editor.
•		 Click the name of the stylesheet in the 

Sheets and rules panel.
•		 Click the style applied to all elements of 

type or class.
•		 Click to create a new style applied to an 

element with specified ID attribute or a 
custom style rule.

•		 Enter a name for the rule or choose an 
existing option from the drop-down list.

•		 Click Create Style rule.
•	 On the Background tab, set the style 

properties for background. 
•		 Click OK.

5.2.2		 Modify CSS rules: font.
•	 On the Tools menu, click CSS Editor.
•		 Click the name of the stylesheet in the 

Sheets and rules panel.
•	 Double-click the rule to modify.
•	 On the Text tab, modify the style 

properties for fonts. 
•		 Click OK.

5.2.2		 Modify CSS rules: background.
•	 On the Tools menu, click CSS Editor.
•		 Click the name of the stylesheet in the 

Sheets and rules panel.
•		 Double-click the rule to modify.
•		 On the Background tab, modify the style 

properties for background. 
•		 Click OK.

5.2.3		 Attach an external CSS to a web page.
•		 On the Tools menu, click CSS Editor.
•		 Click on the drop-down list beside the 

artist’s palette button and click Linked 
stylesheet.

•		 Click Choose File and browse for the 
style sheet.

• Click Open and click OK.
6.1	 Check
6.1.1		 Identify and fix broken links in a website.

•		 On the File menu, click Browse Page. 
•		 Click on links in the page to look for any 

broken links. 
6.1.2		 Recognize good practice in web page 

content:
•	 Including a last updated date
•		 Details of software required to open, view 

files 
•		 Ensuring web browsers compatibility

6.1.3		 Spell check a web page and make changes.
•	 On the Edit menu, click Check Spelling. 
•		 Review the misspelled words and update 

as required.
•		 Click Close.

6.2	 Publish
6.2.1		 Understand the process of uploading a 

website to a web server.
•	 Obtain a web hosting account.
•		 Enter details about the web hosting 

account. 
•		 Create the web pages for upload to the 

website. 
•		 Define the upload method to be used, 

usually FTP. 
•		 Upload the web page files to the web 

server.
•	 Test the website by using a web browser.

6.2.1		 Understand the process of downloading a 
website from a web server.

•	 Create a local folder containing the 
website files. 

•	 Set up an FTP connection.
•	 Select and download files from the web 

server.
6.2.2		 Upload, download a website to, from a 

server.
•	 On the File menu, click Publish. 
•		 On the Settings tab, enter a Site Name.
•		 Enter the HTTP address (URL) of the site.
•		 Enter the Publishing address, the FTP 

address to use for publishing.
•		 Enter the User name and Password and 

check Save Password if required.
• Click Publish. 
• Click Close.

4.2.5		 Add submit button.
•		 On the Insert menu, select Form and click 

Form Field.
•		 Click Submit Button as the Field Type.

4.2.5		 Add reset button.
•		 On the Insert menu, select Form and click 

Form Field.
•		 Click Reset Button as the Field Type.

4.2.5		 Remove submit, reset buttons.
•		 Click to the right of the button and press the 

Backspace Key.
4.2.6		 Set, modify properties for submit, reset 

buttons.
•		 Double-click on the button to set, modify 

properties.
• 		Field Name - Enter the name for the field
• 		Value - Enter the text to appear on the button 
• 		Tab Index - Enter the position in the tab order 

for the field 
• 		Access Key - Enter a shortcut key that will 

take a user to that form field 
4.2.7		 Set, modify form action to send form output by 

email.
•		 Select the location required to insert the form.
•		 On the Insert menu, select Form and click 

Define Form.
•		 Enter a name for the form in the Form Name 

box. 
•		 Enter the URL in the Action URL box.
•		 Click the Method box arrow to select the 

method to transmit the form data to the 
server.

•		 Click OK.

5.1	 CSS Concepts
5.1.1		 Understand the term Cascading Style Sheets 

(CSS), their use and benefits.
•		 A CSS page layout uses the Cascading Style 

Sheets format to organise the content on a 
web page.

•		 Benefits: easier to edit, load faster, smaller 
in size, quick to develop, greater control of 
design.

5.1.2		 Recognize the main approaches to applying 
styles:

•		 Inline 
•		 Internal 
•		 External

5.1.3		 Understand the structure of a CSS rule: 
selector and declaration (property, value).

• 		Declaration - It has two parts, property and 
value 

• 		Selector - Specifies which items in the web 
page will be affected by the declaration

•	 Selector {property:value} 
•	 H2 {color:yellow}

5.2		 Using CSS
5.2.1		 Create, save a new CSS file.

•		 On the Tools menu, click CSS Editor.
•	 Click the name of the stylesheet internal 

stylesheet in the Sheets and rules panel.
•		 Click the drop-down list beside the artist’s 

palette button and select Linked stylesheet.
•		 Click Create Stylesheet.
•		 Click the name of the stylesheet internal 

stylesheet in the Sheets and rules panel 
again.

•		 Click Export stylesheet and switch to 
exported version.

•		 Name the new style sheet with a .css 
extension.

•		 Click Save.
5.2.2		 Create CSS rules: font.

•	 On the Tools menu, click CSS Editor.
•		 Click the name of the stylesheet in the Sheets 

and rules panel.
•		 Click the style applied to all elements of type 

or class.
•		 Click to create a new style applied to an 

element with specified ID attribute or a 
custom style rule.

•	 Enter a name for the rule or choose an 
existing option from the drop-down list.

•		 Click Create Style rule.
•		 On the Text tab, set the style properties for 

fonts. 
•		 Click OK.

5		 Styles

6		 Prepare Upload

For more information, 
visit: www.icdl.org


