
This quick reference is for GIMP 2.8
Image Editing

GIMP Menus / Windows

Keyboard Shortcuts 

Certification Test Goals
This module sets out essential concepts and skills relating to the 
ability to understand the main concepts underlying digital images and 
to use an image editing application to enhance images, apply effects, 
and prepare an image for printing and publishing.

Successful candidates will be able to:
•	 Know about the main concepts of using digital images and 

understand graphic format options and colour concepts.
•	 Open an existing image, save an image in different formats, and 

set image file options.
•	 Use built-in options such as displaying toolbars, palettes to 

enhance productivity.
•	 Capture and save an image, use various selection tools, and 

manipulate images.
•	 Create and use layers, work with text, use effects and filters, and 

use drawing and painting tools.
•	 Prepare images for printing or publishing.

General 
Open  	 Ctrl+O 

Save  	 Ctrl+S 

Print  	 Ctrl+P

Close  	 Ctrl+W 

Undo  	 Ctrl+Z 

Redo  	 Ctrl+Y 

Help  	 F1

Editing 
Cut  	 Ctrl+X 

Copy  	 Ctrl+C 

Paste  	 Ctrl+V

Zoom In	 +

Zoom Out	 -

Selection
Select All  	 Ctrl+A 

Select None	 Shift+Ctrl+A 

Inverse  	 Ctrl+I

1.1	 Digital Images
1.1.1	 Identify common uses of digital images 

like: 
•	 Web and print publishing - Publish 

images to websites, social networks 
or photo sharing sites, or use for print 
publishing (magazines, brochures)

•	 Distribution by e-mail and mobile phone - 
Send your images to friends, colleagues

•	 Home printing - Use a printer, photo 
printer 

•	 Digital photo frames - Display images on 
a digital photo frame

1.1.2	 Understand the terms pixel, resolution.
•	 Pixel - the smallest part of a digital image 

on a screen or a single point in a raster 
image 

•	 Resolution - the measure of the detail 
quality of a digital image

1.1.2	 Identify the key features of a digital image:
•	 Composed of discrete pixels 
•	 Represented digitally in binary code

1.1.3	 Understand the terms lossy, lossless image 
file compression.

•	 Lossy compression creates a smaller 
sized compressed file that results in a 
lower resolution picture with pixel loss.

•		 Lossless compression ensures that the 
compressed data can be reconstructed 
to the exact original image without pixel 
loss.

1.1.4	 Understand the term copyright and the 
implications for image use.

•	 Copyright - the rights granted to use, publish 
or distribute images, or other pieces of work 
for a specific time period

1.1.4	 Understand the terms royalty-free images and 
rights-managed images.

•	 Royalty-free images incur a one-off fee that 
allows the user to use the image as many 
times as required with some restrictions.

•	 Rights-managed images have a copyright 
license which, if purchased by a user, allows 
the one-time use of a photo as specified by 
the license.

1.2		 Graphic Formats
1.2.1	 Understand the terms raster and vector 

graphics and distinguish between them.
•	 Raster graphics - represent a grid of pixels 

and cannot be scaled to a larger size without 
losing quality

•	 	Vector graphics - created using points, lines 
and curves, based on mathematical equations 
and can be scaled to a large size without 
losing quality

1.2.1	 Identify common raster (jpeg, gif) and vector 
(svg, eps) formats.

Raster File Format File Extension
Joint Photographic Experts Group 
(JPEG)

.jpeg

Graphics Interchange Format (GIF) .gif

Vector File Format File Extension
Scalable Vector Graphics (SVG) .svg

Encapsulated PostScript (EPS) .eps

1.2.2	 Recognize proprietary digital image editing 
application formats:

File Format File Extension
Photoshop Native Format .psd

Paint Shop Pro Native Format .psp

GIMP Native Format .xcf

Corel Photo-Paint Format .cpt

1.3		 Colour Concepts
1.3.1		 Understand the term colour model.

•		 A mathematical model describing how 
colours can be represented as lists of 
numbers, typically as three or four values 
or colour components.

1.3.1		 Recognize common colour models: 
•	 RGB - Combines red, green and blue 
•	 	HSB - Combines hue, saturation and 

brightness
•	 CMYK - Combines cyan, magenta, yellow 

and key (black)
•	 	Grayscale - Combines shades of gray, 

varying from black to white

1.3.2		 Understand the terms colour palette, 
colour depth.

•		 Colour palette - the total colours available 
•	 Colour depth - the maximum number of 
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distinct colours that are used in an image, 
higher depth gives a broader range of 
distinct colours and a more realistic 
image

1.3.2		 Understand the terms hue, saturation, 
colour balance.

•		 Hue - A pure colour described by name 
like red or yellow

•	 	Saturation - The dominance of hue in the 
colour

•	 Colour balance - The overall adjustment 
of the intensities of the colours

1.3.2		 Understand the terms contrast, brightness, 
gamma.

•	 Contrast - The difference in colour and 
light level in an image

•	 	Brightness - The degree to which an 
image radiates light

•	 Gamma - The way brightness is changed 
for the middle range of gray tones

1.3.2		 Understand the term transparency.
•	 Transparency - The ability of light to 

transmit through an image

2.1		 Capturing Images
2.1.1	 	Save an image from a digital camera to a 

location on a drive.
•	 Connect the digital camera to the 

computer. 
•		 Follow the Wizard instructions to choose 

the image to save.
•		 Select the location on the drive and save 

the image.

2.1.2		 Use the print screen facility to capture a full 
screen.

•		 Press the Print Screen key. 
•	 Open an image editing application.
•		 Click the Edit menu. 
•	 Click Paste.

2.1.2		 Use the print screen facility to capture an 
active window.

•	 Open a window on the desktop.
•	 Press the Alt key + Print Screen key on 

the keyboard.
•	 Open an image editing application. 
•		 Click the Edit menu.
•	 Click Paste.

2.1.3		 Save an image from an image library, web 
page to a location on a drive

•	 Right-click the image. 
•	 Select Save image as.
•		 Create a file name and navigate to the 

location required. 
•	 Click Save.

2.1.4		 Open a scanning application and scan an 
image: preview, set scanning parameters, 
scan, save.

•	 Place the image on the scanner. 
•	 Click scan to view options.
•		 Follow the instructions to choose the 

scanning parameters.
•	 Navigate to the location required to save 

the image and scan.

3.1		 Image Creation
3.1.1		 Open an image editing application.

•	 Click the Start button. 
•	 Select All Programs.
•	 Click GIMP2.

3.1.1		 Close an image editing application.
•	 On the File menu, click Quit.

3.1.1		 Open image files.
•	 On the File menu, click Open.
•	 Select file(s) to open and click Open.

3.1.1		 Close image files.
•	 On the File menu, click Close to close 

the current image window or Close all to 
close all opened images.

3.1.2		 Create a new image file and set options: 
colour model, size, resolution, background 
colour.

•	 On the File menu, click New.

•		 To set grid settings, on the Edit menu, 
click Preferences.

•		 Click Default Grid.
•		 Click the grid Line style, Foreground color 

and Background color.
•		 Enter the gridline spacing and offset 

required.
•		 Click OK.
•	 To set measurement units, on the Edit 

menu, click Units. 
•		 Check the checkboxes for the Units 

required.
•	 Click Close.

3.3.2		 Use available Help functions.
•	 On the Help menu, click Help.

3.3.3		 Use magnification/zoom tools.
•	 On the View menu, select Zoom (100%) 

and click Zoom Out or Zoom In.

3.3.4		 Use the undo, redo command.
•		 On the Edit menu, click Undo or Redo.

3.3.4		 Use the undo history.
•	 On the Edit menu, click Undo History. 
•		 Select a state in the file history to revert to.

3.3.5		 Display, hide built-in toolbars, palettes, 
windows.

•	 On the Window menu, select/deselect 
appropriate toolbar, palette, window.

4.1		 Selection
4.1.1		 Select an entire image, layer(s).

•	 To select an entire image, on the Select 
menu, click All.

•		 To select a layer, in the Layers panel, click 
the layer required.

4.1.2		 Set selection tool properties: relationship 
between multiple selections, feathering, 
antialiasing, width, height.

•	 In the Toolbox, click the required 
Selection Tool, choosing from the 
Rectangle, Ellipse, Free, Fuzzy, Select by 
color, Scissors Select Tool.

•	 In the Tool Options, select the required 
relationship between selections option. 

•	 Check the feathering and antialiasing 
check boxes and enter the width and 
height required.

•		 Set the file options. 
•	 Click OK.

3.1.3		 Create a new image file from clipboard.
•	 Ensure an item has been copied to the 

clipboard. 
•	 On the File menu, select Create.
•	 Click From Clipboard.

3.1.4		 Switch between open image files.

•	 On the Windows menu, select Dockable 
Dialogs. 

•	 Click Images.
•	 Click the image file required from the Images 

dialog to switch to that file.

3.1.5		 Save an image to a location on a drive.
•		 On the File menu, click Save.
•	 Create a file name and navigate to the 

required location. 
•	 Click Save.

3.1.5	 	Save an image under another name to a 
location on a drive.

•	 On the File menu, click Save As.
•	 Enter a new file name over the existing file 

name and navigate to the location required.
•	 Click Save.

3.1.6		 Save, export an image as another file type like: 
jpeg, gif, tiff, png.

•	 On the File menu, click Export.
•	 Click the Select File Type (By Extension) drop-

down menu and click a file type.
•	 Click Export.

3.2		 Settings
3.2.1		 Set background colour, foreground colour.

•		 In the Toolbox, click the Set Background 
Color or Set Foreground Color option.

•	 Select the colour required. 
•	 Click OK.

3.2.2		 Set grid properties: units, horizontal spacing, 
vertical spacing, colour.

•	 On the Edit menu, click Preferences. 
•	 Click Default Grid.
•		 Click the Line style, Foreground color and 

Background color required.
•		 Enter the spacing and offset required.
•	 Click OK.

3.3		 Enhancing  Productivity
3.3.1		 Set basic options/ preferences in the 

application like: transparency, grid settings, 
measurement units.

•	 To set transparency, on the Edit menu, click 
Preferences. 

•		 Click Display.
•		 Click the transparency Check style and Check 

size required. 
•		 Click OK.

2		 Image Capture

3		 Using the Application

4		 Working with Images



4.1.3		 Select part of an image using selection 
tools: rectangular, elliptic, magic wand, 
magnetic lasso, freehand image.

Selection Tool Description
Rectangle / 
Ellipse select 
tool

Draws square or rectangular 
selection borders or draws round or 
elliptical selection borders.

Fuzzy select tool 
(Magic Wand)

Selects pixels of similar colour with 
one click.

Scissors select 
tool

Draws a selection border using 
intelligent edge fitting.

Free select tool 
(Lasso)

Draws freehand selection borders. 
This tool is great for making very 
precise selections.

•	 In the Toolbox, click the required 
Selection Tool.

•	 Select a part of the image using the tool.

4.1.4		 Inverse a selection.
•		 In the Toolbox, click the required 

Selection Tool.
•		 Select a part of the image using the tool.  
•		 On the Select menu, click Invert.

4.1.5		 Save a selection.
•		 In the Toolbox, click the required 

Selection Tool.
•	 Select a part of the image using the tool. 
•		 On the Select menu, click Save to 

Channel. Enter a Selection Name.
•	 Click OK.

4.1.5		 Load a saved selection
•		 In the Channels panel, choose the 

required selection.
•		 Click the red square icon to load the 

selection.

4.2		 Image Manipulation
4.2.1		 Change the canvas size of an image.

•	 On the Image menu, click Canvas Size.
•		 Enter the width and height required.
•		 Click Resize.

4.2.2		 Resize an image in pixels, measurement 
units.

•	 On the Image menu, click Scale Image.
•		 Enter the width and height required.
•		 Select the required measurement unit.
•		 Click Scale.

4.2.3		 Crop an image.
•	 In the Toolbox, click the Crop Tool.
•		 Click and drag to select the part of the 

image you wish to crop using the tool.
•	 Press the Return key to accept changes.

4.2.4		 Copy image(s), selection within an image.
•	 In the Toolbox, click the Move Tool.
•		 Select the image and click Ctrl + C to 

copy.
•		 Paste the image selection into the desired 

location.

4.2.4		 Move image(s), selection within an image.
•		 In the Toolbox, click the Move Tool.
•	 Select the image and click and drag to 

move.

4.3.4		 Flatten layers.
•		 On the Image menu, click Flatten Image 

to merge all layers into one.

4.3.5		 Transform layer(s): scale.
•		 Select the layer to transform.
•	 On the Layer menu, click Scale Layer.
•		 Enter the desired Layer Size and Quality.
•	 Click Scale.

4.3.5		 Transform layer(s): rotate.
•		 Select the layer to transform.
•		 On the Layer menu, click Transform 

and select the appropriate layer rotation 
option.

4.3.5		 Transform layer(s): flip.
•	 Select the layer to transform.
•		 On the Layer menu, click Transform and 

select the appropriate layer flip option.

4.3.5		 Transform layer(s): move.
•		 In the Layers panel, select the layer to 

move. 
•	 Click the Move Tool, click and drag the 

layer to the required location.

4.3.5		 Transform layer(s): trim.
•	 On the Layer menu, click Layer Boundary 

Size. 
•		 In the Toolbox, click the Crop Tool. 
•		 Enter the required Layer Size and Offset.
•	 Click Resize.

4.3.6		 Convert a drawn object to a raster layer.
•		 Select a text layer.
•	 On the Layer menu, click Discard Text 

Information.
		 Note: Only text layers can be converted to 

a raster layer in GIMP.

4.3.7		 Create an animated gif from layers.
•	 On the File menu, click Export.
•	 Create a file name and navigate to the 

location required. 
•		 Select GIF image as the file type.

•	 Check the As animation GIF Option 
checkbox and select any additional loop 
and frame delay settings. 

•		 Click Export.
•		 Click Save.

		 Note: You must have two or more layers to 
create an animated gif.

4.4	 Text
4.4.1		 Add text.

•		 In the Toolbox, click the Text Tool.
•	 Click and drag on the image to create a 

text editing region.
•		 On the Options bar, select text options 

and enter text.
•		 Click outside the text editing region to 

accept changes.

4.4.1		 Edit text.
•	 In the Toolbox, click the Text Tool.
•	 Double-click on existing text to open the 

text editing region.
•		 Edit the text as required.
•		 Click outside the text editing region to 

accept changes.

4.4.1		 Delete text.
•		 In the Toolbox, click the Text Tool.
•		 Double-click on existing text to open the 

text editing region.
•		 Delete the text as required. 
•		 Click outside the text editing region to 

accept changes.

4.2.5		 Rotate, mirror an image, selection within an 
image.

•		 In the Toolbox, click the required Selection 
Tool.

•	 Select the image, part of image you wish to 
rotate, mirror.

•	 On the Image menu, click Transform and click 
the required rotation or flip (mirror) option.

4.3	 Layers
4.3.1		 Define and understand the term layer.

•		 Layers are used to separate different 
elements of an image and are stacked on top 
of each other.

4.3.2		 Create a layer.
•		 On the Layer menu, click New Layer. 
•		 Enter the Layer Name, Width, Height required. 
•		 Check the Layer Fill Type check box required. 
•	 Click OK.

4.3.2		 Copy a layer.
•	 In the Layers panel, select the layer to copy.
•		 On the Layer menu, click Duplicate Layer. 
•		 Edit a new layer name in the Layers dialog.

4.3.2		 Delete a layer.
•		 In the Layers panel, select the layer to delete.
•		 On the Layer menu, click Delete Layer.

4.3.3		 Set layer properties: name.

•		 In the Layers panel, double-click the layer to 
open layer properties.

•		 Edit the Layer Name. 
•		 Click OK.

4.3.3		 Set layer properties: hide, show.
•	 In the Layers panel, click the Eye symbol to 

Show/Hide a layer.

4.3.3		 Set layer properties: lock.
•		 In the Layers panel, click to the right of Lock 

to Lock pixels or Lock alpha channel.

4.3.3		 Set layer properties: opacity.
•		 In the Layers panel, adjust the Opacity slider 

to select the appropriate opacity.

4.3.3		 Set layer properties: blending mode.
•		 In the Layers panel, click the Mode drop-

down arrow. 
•	 Select the appropriate blending mode.

4.3.4		 Arrange layers.
•	 On the Layer menu, click Stack.
•		 Select the appropriate option to Raise / Lower 

the layer.

4.3.4		 Merge layers.
•		 In the Layers panel, select the layer to merge.
•	 On the Layer menu, click Merge Down to 

merge to the layer below.

4.3.4		 Link layers.
•		 In the Layers Panel, click to the right of the 

Eye symbol on appropriate layers to link these 
layers.
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4.4.2		 Copy, move text.
•		 In the Toolbox, click the Text Tool.
•	 Double-click on existing text to open the 

text editing region.
•		 Select the text to copy, move.
•		 On the Edit menu, click Cut or Copy. 
•		 Paste the text into the desired location.

4.4.3		 Align text: left, centre, right, justified.
•		 In the Toolbox, click the Text Tool.
•		 Double-click on existing text to open the 

text editing region.
•		 Select the text to align.
•		 In the Tool Options, select the desired 

justify alignment. 

4.4.4		 Apply text formatting: font sizes, font types, 
font colour.

•		 In the Toolbox, click the Text Tool.
•		 Double-click on existing text to open the 

text editing region.
•		 Select the text to format.
•	 On the Options bar, select the desired 

font size, font type or font colour.
•		 Click OK to accept font colour changes.

4.4.5		 Apply a text warp.

•	 In the Toolbox, click the Text Tool.
•		 Double-click on existing text to open the 

text editing region.
•		 Select the text to text warp.
•	 On the Filters menu, click Distorts and 

Curve Bend. 
•		 Select the desired Curve and adjust 

settings for Border, Type and Rotate.
•		 Click OK.

4.5		 Effects and Filters
4.5.1		 Apply artistic, distortion effects: pixelate, 

emboss, wind, ripple, twirl, desaturate.
•	 Select the image, part of image using a 

Select Tool from the Toolbox.
•		 To apply a pixelate effect, on the Filters 

menu, select Blur and click Pixelize.
•		 To apply an emboss effect, on the Filters 

menu, select Distorts and click Emboss.
•		 To apply a wind effect, on the Filters 

menu, select Distorts and click Wind.
•		 To apply a ripple effect, on the Filters 

menu, select Distorts and click Ripple.
•		 To apply a twirl effect, on the Filters 

menu, select Distorts and click Whirl and 
Pinch.

•		 To apply a desaturate effect, on the 
Colors menu, click Desaturate.

•		 Adjust the settings as required. 
•		 Click OK.

4.5.2		 Apply blur effects: gaussian, motion.
•		 Select the image, part of image using a 

Select Tool from the Toolbox.
•	 To apply a Gaussian blur effect, on 

the Filters menu, select Blur and click 
Gaussian Blur.

•		 To apply a motion blur, on the Filters 
menu, select Blur and click Motion Blur.

•		 Adjust the settings as required.
•		 Click OK.

4.5.3		 Apply lighting effects: lighting, flare.
•	 Select the image, part of image using a 

Select Tool from the Toolbox.
•	 To apply a lighting effect, on the Filters 

menu, select Light and Shadow and click 
Lighting Effects.

•		 To apply a flare effect, on the Filters 
menu, select Light and Shadow and click 
Lens Flare.

•		 Adjust the settings as required.
•		 Click OK.

5.2.6		 Clone a portion of an image using a clone 
tool, selecting size, opacity.

•		 In the Toolbox, click the Clone Tool.
•		 In the Tool Options, click the Opacity, 

Brush and Size required, and adjust other 
settings as required.

•	 Hold the Ctrl key and make your clone 
selection. 

•		 Click the required location to place the 
cloned content.

6.1	 Setup
6.1.1		 Preview an image.

•	 On the File menu, click Print. 
•	 Click the Image Settings tab to view the 

print preview.

6.1.2		 Select appropriate colour depth, resolution, 
image size, graphic format for web, screen, 
print use.

•	 To adjust colour depth, on the Image 
menu, click Mode.

•		 Click the colour depth mode required.
•	 To adjust resolution or image size, on the 

Image menu, click Scale Image.
•		 Click the resolution or image size 

required. 
•	 To adjust graphic format, on the File 

menu, click Export.
•	 Click the graphic format required. 
•	 Click Export.

6.2	 Print
6.2.1		 Change print output orientation: portrait, 

landscape. 
•		 On the File menu, click Print. 
•		 On the General tab, click Preferences. 
•	 Under Orientation, click Portrait or 

Landscape.
•		 Click OK.

6.2.1		 Change paper size.
•		 On the File menu, click Print. 
•	 On the General tab, click Preferences. 
•	 Under Paper sizes, click the paper size 

required.
•	 Click OK.

6.2.2		 Print an image to an installed printer using 
defined options, default settings.

•	 On the File menu, click Print.
•	 Select additional print options if required. 
•		 Click Print.

4.5.4		 Apply adjustments: brightness-contrast, hue-
saturation, colour balance.

•		 Select the image, part of image using a Select 
Tool from the Toolbox.

•	 To adjust brightness-contrast, on the Colors 
menu, click Brightness-Contrast. 

•		 To adjust hue-saturation, on the Colors menu, 
click Adjust Hue-Saturation. 

•	 To adjust colour balance, on the Colors menu, 
click Color Balance. 

•		 Adjust the settings as required. 
•	 Click OK.

4.5.5		 Apply sharpen mask.
•	 Select the image, part of image using a Select 

Tool from the Toolbox.
•	 On the Filters menu, select Enhance and click 

Sharpen.
•	 Adjust the settings as required. 
•		 Click OK.

4.5.5		 Apply unsharpen mask.
•	 On the Filters menu, select Enhance and click 

Unsharp Mask.
•		 Adjust the settings as required. 
•		 Click OK.

4.5.6		 Apply red eye reduction.
•	 Select the image, part of image using a Select 

Tool from the Toolbox.
•		 On the Filters menu, select Enhance and click 

Red Eye Removal.
•	 Adjust the settings as required.
•		 Click OK.

5.1		 Drawing Tools
5.1.1		 Add a line to an image: straight line, free drawn 

line, curves. Set, modify line weight, style and 
colour.

•		 In the Toolbox, click the Paintbrush Tool or 
Pencil Tool. 

•	 In the Tool Options, select the desired Brush, 
Size, Aspect Ratio and Angle.

•	 Draw the line.

5.1.2		 Add a shape to an image: rectangle, ellipse,n-
shaped polygon. Set, modify line, fill style and 
colour.

•		 In the Toolbox, click the Rectangle Select 
Tool, Free Select Tool or Ellipse Select Tool.

•		 Draw the shape using the select tool.
•		 To create a filled shape, in the Toolbox, 

choose a foreground color and fill the 
selection with the Bucket Fill Tool.

•	 To create an outline shape, on the Edit menu, 
click Stroke Selection. 

•		 Adjust the settings as required and click 
Stroke.

5.2		 Painting Tools
5.2.1		 Pick up a colour value with the dropper.

•		 In the Toolbox, click the Color Picker Tool.
•		 Select the colour of the image to pick and 

click that colour to select.

5.2.2		 Fill a portion of an image with the gradient tool, 
selecting opacity/transparency, radial, linear, 
position, rotation.

•		 In the Toolbox, click the Blend Tool. 
•		 In the Tool Options, click the required Opacity, 

Gradient, Shape, Repeat and Offset.
•		 Click the gradient start location and drag to a 

finish location to apply the gradient.

5.2.3		 Colour a portion of an image with the 
paintbrush tool, selecting colour, shape, size.

•	 In the Toolbox, click the Paintbrush Tool and 
click a Foreground Color.

•		 In the Tool Options, click the Brush and Size 
required.

•		 Colour the portion of the image.

5.2.4		 Erase a portion of an image with the eraser 
tool, selecting its shape and size.

•		 In the Toolbox, click the Eraser Tool.
•		 In the Tool Options, click the Brush and Size 

required.
•		 Erase the portion of the image.

5.2.5		 Fill a portion of an image with colour using the 
paint bucket tool.

•		 In the Toolbox, click the Bucket Fill Tool.
•		 Click a Foreground Color.
•		 Fill the portion of the image with the colour.
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