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1 Understanding Databases 

1.1 Key Concepts 

1.1.1 Understand what a database is. 

 A collection of related data organised for fast search 
and retrieval. 

1.1.2 Understand that information is the processed 
output of data. 

 Information is data that has been organised, 
structured and contextualised to give it meaning and 
purpose.  

1.1.3 Understand how a database is organised in terms 
of tables, records and fields. 

 Tables – Data arranged in rows and columns. 

 Records – A complete set of information in a table. 

 Fields – The smallest units of information that can 
be accessed. 

1.1.4 Understand that all database data is stored in 
tables. Understand that changes are automatically 
saved.  

 All data entered into Access is stored in tables. Any 
changes made to this data is automatically saved by 
the program. 

1.1.5 Know some of the common uses of databases 
like: 

 Social networks. 

 Booking systems. 

 Government records. 

 Bank account records. 

 Hospital patient details. 

1.2 Database Organisation 

1.2.1 Understand that each table in a database should 
contain data related to a single subject type. 

 When tables contain data related to a single subject 
type, it is easier to search for and locate data.  

1.2.2 Understand that each record in a database should 
contain data related to a single subject. 

 A collection of related data organised for fast search 
and retrieval. 

1.2.3 Understand that each field in a table should 
contain only one element of data. 

 For example, first name in one field, surname in 
second field. 

1.2.4 Understand that field content is associated with an 
appropriate data type like: short text, number, 
date/time, yes/no. 

 Data Type – The characteristic of a field that 
determines what type of data it can hold. 

Purpose  Keyboard Shortcut 

Open a database Ctrl+O 
Save a database Ctrl+S 
Print a database Ctrl+P 
Close a database Ctrl+W 
Undo Ctrl+Z 
Redo or Repeat Ctrl+Y 
Help F1 
Switch between apps Alt+Tab 
Next field Tab 
Previous field Shift+Tab 
Up one screen Page Up 
Down one screen Page Down 
First record Ctrl+Home 
Last record Ctrl+End 
Cut Ctrl+X 
Copy Ctrl+C 
Paste Ctrl+V 
Properties Alt+Tab 
Open object in design view Ctrl+Enter 
Save object Ctrl+S 
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Certification Test Goals 

 This module sets out essential concepts and skills relating to understanding the 
concept of a database and demonstrating competence in using a database 
application. 
 
Successful candidates will be able to: 

 Understand what a database is and how it is organised. 

 Create a simple database and view the database content in various 
modes. 

 Create a table, define and modify fields, and create relationships between 
tables. Enter and edit data in a table. 

 Use filters and queries to retrieve specific information from a database. 

 Create a form to enter, modify and delete records and data in records.  

 Create routine reports and prepare outputs ready for print or electronic 

distribution. 

Keyboard Shortcuts 
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 The following are examples of different data types: 

Short Text Text, numbers, or both 
up to 255 characters. 

Long Text Text, numbers, or both 
up to 65, 536 
characters. 

Number Numbers used in 
calculations. 

Large Number Used to efficiently 
calculate large 
numbers. 

Date/Time Date, times, or both up 
to 8 bytes. 

Currency Currency values 
prevents rounding. 

AutoNumber Unique sequential 
numbers automatically 
added to field. 

Yes/No True/False On/Off. 

OLE Object Documents created in 
other Office programs 
up to 1GB. 

Hyperlink Hyperlink to a UNC 
path or URL up to 
2048 characters. 

Attachment  Stores one or more file 
attachments in one 
field. 

Calculated Data created using a 
formula, calculated 
value can later be 
retrieved to use again. 

Lookup Wizard Create a field that 
allows the choice of a 
value from another 
table or list. 

 

1.2.5 Understand that fields have associated field 
properties like: field size, format, default value. 

 Field Properties – A set of characteristics that 
control how the field is stored, entered, or displayed.  

1.2.6 Understand what a primary key is. 

 It uniquely identifies each record in a table to avoid 
data duplication and to allow faster data access.  

 Examples include Order ID, Product ID, Customer 
ID or Autonumber.  

1.2.7 Understand that the main purpose of an index is to 
speed up search queries.  

 It helps find and sort records faster.  

1.3 Relationships 

1.3.1 Understand that the main purpose of relating 
tables in a database is to minimise duplication of 
data.  

 Minimising duplication of data helps to ensure the 
integrity of the data.  

1.3.2 Understand that a relationship is built by matching 
a unique field in one table with a field in another 
table.  

 It is not possible to match duplicate field names; 
each field has its own unique identifier. 

1.3.3 Understand the importance of maintaining the 
integrity of relationships between tables.  

 Integrity ensures that relationships are valid. 
Integrity avoids records being accidentally deleted 
or altered.  

2 Using the Application 

2.1 Working with Databases 

2.1.1 Open a database application. 

 Click the Start button. 

 Scroll to Access 2016. 

 Click Access 2016. 

2.1.1 Close a database application. 

 Click the ‘x’ icon on the top right of the window. 

2.1.2 Open a database. 

 On the File tab, click Open. 

 Click Browse. 

 Navigate to the database to open and click Open.  

2.1.2 Close a database. 

 On the File tab, click Close Database.  

2.1.3 Create a new database and save to a location on a 
drive. 

 

 On the File tab, click New. 

 Click Blank database. 

 Enter a file name in the File Name box. 

 Beside the File Name box, click the Folder button.  

 Navigate to the location required.  

 Click OK.  

 Click Create.  

2.1.4 Restore, minimise the ribbon. 

 Double-click any tab to minimise the ribbon.  

 Double-click any tab again to restore the ribbon.  

2.1.5 Use available help resources. 

 Click on the File tab. 

 Click on the Help button on the top right of the 
window. 

2.2 Common Tasks 

2.2.1 Open a table, query, form, report. 

 Select the table, query, form or report in the 
Navigation Pane. 

 Double-click the object.  

2.2.1 Save a table, query, form, report.  

 Ensure the table, query, form or report is open.  

 Click the Save button on the Quick Access Toolbar.  

2.2.1 Close a table, query, form, report.  

 Click the close ‘x’ icon on the top-right of the object 
window.  

2.2.2 Switch between view modes in a table, query, 
form, report.  

 

 On the Home tab, in the Views group, click the View 
arrow and click the preferred view. 

2.2.3 Delete a table, query, form, report. 

 Select the table, query, form, or report in the 
Navigation Pane. 

 On the Home tab, in the Records group, press the 
Delete button. 

 Click Yes to confirm deletion. 

2.2.4 Navigate between records in a table, query, form.  

 

 Use the Navigation bar in the lower left corner of the 
window to go forward or backwards through the 
records.  

2.2.4 Navigate between pages in a report.  

 Click File and then click Print. 

 Click Print Preview. 

 Beside the Page: box in the report, click the Next 
Page or Previous Page button.  

2.2.5 Sort records in a table, form, query output in 
ascending, descending numeric, alphabetic order.  

 Click a field in the table, form, query to sort. 

 On the Home tab, in the Sort & Filter group, click 
the Ascending or Descending buttons. 

3 Tables 

3.1 Records 

3.1.1 Add records in a table. 

 In Datasheet View, on the Home tab, in the Records 
group, click the New button.  

 Enter data in fields required.  

3.1.1 Delete records in a table.  

 Select the record to delete. 

 On the Home tab, in the Records group, click the 
Delete button.  

 Click Yes to confirm deletion.  

3.1.2 Add, modify data in a record. 

 In Datasheet View, click the record to add or modify 
the data.  

3.1.2 Delete data in a record.  

 In Datasheet View, select the data to delete and 
press the Delete key.  

3.2 Design 

3.2.1 Create and name a table. 

 On the Create tab, in the Tables group, click the 
Table button.  

 On the Fields tab, in the Views group, click the View 
button. 

 Click Design View.  

 When prompted, enter a name for the table and 
click OK.  

 3.2.1 Specify fields with their data types like: short text, 
number, date/time, yes/no. 

 

 In Design View, click the Data Type column for the 
field. 

 Click the drop-down arrow and select a Data Type.  

3.2.2 Apply field property settings: field size, default 
value.  

 In Design View, click a field row.  

 On the General tab at the bottom of the window, 
click the Field Size or Default Value box.  

 Enter or modify values as required. 

3.2.2 Apply field property settings: number format, 
date/time format. 

 

 In Design View, click a field. 

 On the General tab at the bottom of the window, 
click the Format box.  

 Click the drop-down arrow and select a Format.  

3.2.3 Understand consequences of changing data types, 
field properties in a table.  

 Data already entered into a table may be lost when 
a field attribute such as field size is changed or a 
data type such as short text is changed to number, 

3.2.4 Create a simple validation rule for numbers.  

 In Design View, click a field.  

 On the General tab at the bottom of the window, 
click the Validation Rule field.  

 Enter the validation rule required.  

3.2.5 Set a field as a primary key. 

 In Design View, click the field to select as the 
primary key. 

 On the Design tab, in the Tools group, click the 
Primary Key button.  

3.2.6 Index a field with, without duplicates allowed. 

 In Design View, click the field row. 

 On the General tab at the bottom of the window, 
click the field property Indexed. 

 Click the drop-down list and click Yes (No 
Duplicates) or click Yes (Duplicates OK). 

3.2.7 Add a field to an existing table. 

 In Design View, click an empty field row.  

 Enter a new field name. 

 Click a Data Type from the drop-down list. 

3.2.8 Adjust the width of column(s) in a table.  
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 In Datasheet View, select the column heading.  

 On the Home tab, in the Records group, click the 
More button.  

 Click Field Width. 

 Enter a width in the Column Width box.  

 Click OK. 

3.3 Relationships 

3.3.1 Create a one-to-many relationship between tables.  

 On the Database Tools tab, in the Relationships 
group, click Relationships. 

 On the Design tab, in the Relationships group, click 
Show Table. 

 Select one or more tables, click Add. Click Close. 

 Drag a field from one table to the common field in 
the other table.  

 In the Edit Relationships dialog box, confirm that 
field names shown are the common fields for the 
relationship. 

 The field on the one side of the relationship must 
have a unique index. The Indexed property must be 
set to Yes (No Duplicates), for example a primary 
key. 

 The field on the many side should not have a 
unique index. The Indexed property must be set to 
either No or Yes (Duplicates OK). 

 Click Create. 

 When finished in the Relationships window, click 
Save to save the relationship layout changes.  

3.3.2 Delete a one-to-many relationship between tables. 

 On the Database Tools tab, in the Relationships 
group, click Relationships. 

 On the Design tab, in the Relationships group, click 
All Relationships.  

 Click the relationship line for the relationship you 
wish to delete.  

 Press the Delete key. 

 Click Yes. 

 Click Save to save changes.  

3.3.3 Apply referential integrity between tables. 

 In the Relationships window, click the relationship 
line for the relationship to change.  

 Double-click the relationship line you wish to 
change. 

 In the Edit Relationships box, select the Enforce 
Referential Integrity check box.  

 Make any additional changes to the relationship, 
click OK. 

4 Retrieving Information 

4.1 Main Operations 

4.1.1 Use the search command for a specific word, 
number, date in a field. 

 

 On the Home tab, in the Find group, click the Find 
button. 

 Enter the word, number or date to find the Find 
What: box. 

 Ensure Current document is selected in the Look In 
box and Any Part of Field is selected in the Match 
box.  

 Click Find Next until the value is found. 

4.1.2 Apply a filter to a table, form. 

 

 Open the table or form. 

 On the Home tab, in the Sort & Filter group, click 
the Filter button.  

 Check the boxes to deselect the rows to filter. 

 Click OK. 

4.1.3 Remove filter from a table, form. 

 On the Home tab, in the Sort & Filter group, click 
the Advanced button. 

 Click Clear All Filters.  

4.2 Queries 

4.2.1 Understand that a query is used to extract and 
analyse data. 

 Queries allow users to locate data according to 
specific search criteria.  

4.2.2 Create a named single-table query using specific 
search criteria. 

 

 On the Create tab, in the Queries group, click the 
Query Design button. 

 Select the table to add from the Show Table 
window. 

 Click Add and then click Close. 

 Click and drag the fields required into the Field row 
in the window below.  

 Click the Criteria box of the field to query. 

 Enter the query criteria. 

 Close the query and then click Yes to confirm and 
save. 

 Enter the name required in the Query Name box. 

 Click OK. 

4.2.3 Create a named two-table query using specific 
search criteria. 

 

 On the Create tab, in the Queries group, click the 
Query Design button. 

 Select the tables to add from the Show Table 
window. 

 Click Add and then click Close. 

 Click and drag the fields required into the Field row 
in the window below. 

 Click the Criteria box of the field to query. 

 Enter the query criteria. 

 Close the query and click Yes to confirm save. 

 Enter the name required in the Query Name box. 

 Click OK. 

4.2.4 Add criteria to a query using one or more 
operators: = (Equal), <> (Not equal to), < (Less 
than), <= (Less than or equal to), > (Greater than), 
>= (Greater than or equal to). 

 

 In Design View, click into the Criteria box of the field 
to be queried. 

 Enter the criteria using a logical operator. 

4.2.5 Add criteria to a query to sort records in 
ascending, descending numeric, alphabetic order.  

 In Design View, identify the fields to specify the 
criteria for. 

 On the Home tab, in the Sort & Filter group, sort the 
criteria by selecting the Ascending or Descending 
command.  

4.2.6 Add criteria to a query using one or more logical 
operators: AND, OR, NOT. 

 In Design View, click into the Criteria box of the field 
to be queried. 

 Enter the criteria using a logical operator.  

4.2.7 Use a wildcard in a query, * or %,? Or _. 

 In Design View, click into the Criteria box of the field 
to be queried.  

 Enter the criteria using a wildcard. 

4.2.8 Edit a query: modify, remove criteria. 

 In Design View, click into the Criteria box of the field 
to be queried.  

 Modify, or remove criteria as required. 

4.2.9 Edit a query: add fields. 

 

 In Design View, click the field box of a blank 
column. 

 Click the drop-down arrow that appears. 

 Click the field to add to the query. 

4.2.9 Edit a query: remove fields. 

 

 In Design View, select the column heading of the 
field to delete. 

 Press the Delete key. 

4.2.9 Edit a query: move fields. 

 In Design View, select the column heading of the 
field to move. 

 Drag and drop the field’s column heading to the 
required location. 

4.2.9 Edit a query: hide, unhide fields. 

 To hide a field, in the query, select by right-clicking 
the field to be hidden. Click Hide Fields. 

 To unhide a field, right-click any of the fields and 
click Unhide Fields.  

 In the Unhide Columns dialog box, select the 
checkbox of the field to be unhidden and click 
Close.  

4.2.10 Run a query. 
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 On the Design tab, in the Results group, click the 
Run button. 

5 Forms 

5.1 Using Forms 

5.1.1 Understand that a form is used to display, add and 
edit records. 

 Forms allow users to view and navigate through 
records and add, delete, or modify records as 
needed. 

5.1.2 Create and name a simple form. 

 Select a table or query. 

 On the Create tab, in the Forms group, click the 
Form button. 

 Close the form and when prompted, click Yes to 
save. 

 Enter the name required in the Form Name: box. 

 Click OK. 

5.1.3 Use a form to insert new records. 

 

 Ensure the form is open.  

 On the Home tab, in the Records group, click the 
New button.  

 Enter data in the fields of the new record as 
required. 

5.1.4 Use a form to delete records. 

 Ensure the form is open. 

 Select the record to delete. 

 On the Home tab, in the Records group, click the 
Delete arrow. 

 Click Delete Record. 

 Click Yes to confirm deletion. 

5.1.5 Use a form to add, modify, delete data in a record. 

 Enter the number of the required record in the 
Navigation bar at the bottom of the form window. 

 Press the Return key. 

 Click the field to alter and add, modify or delete data 
as required. 

5.1.6 Add text in headers, footers in a form. 

 

 In Design View, on the Design tab, in the Controls 
group, click the Label button. 

 Go to the header or footer and click and drag to 
create a text box. 

 Add the text required.  

5.1.6 Modify text in headers, footers in a form. 

 In Design View, click the text in the header or footer. 

 Modify the text as required.  

6 Outputs 

6.1 Reports, Data, Export 

6.1.1 Understand that a report is used to present 
selected information from a table, query. 

 Reports allow users to create a printed copy of all or 
selected data from a table or query for greater ease 
of reference and understanding.  

6.1.2 Create and name a simple report based on a table, 
query. 

 Select a table or query. 

 On the Create tab, in the Reports group, click the 
Report button. 

 Close the report and, when prompted, click Yes to 
save and then confirm the name of report and click 
OK. 

6.1.3 Create and name a grouped report.  

 On the Create tab, in the Reports group, click 
Report Wizard.  

 Select the fields to include on the report by using 
the arrows located between the Available Fields: 

and Selected Fields: windows. Click Next > when 
finished. 

 Add the grouping levels by double-clicking a field 
name in the list, or with the arrow buttons.  

 Click Grouping Options… 

 Set the Grouping intervals: as desired and click OK. 

 Click Next > when finished. 

 Select how data will be sorted. Click Next >  

 Select how the data will be viewed. Click Next > 
when finished. 

 To name a report, on the final step of the Report 
Wizard edit the title of the report in the What title do 
you want for your report? box. 

6.1.3 Sort records in a grouped report. 

 In the Report Wizard, click the first drop-down list 
and choose a field on which to sort. Choose 
Ascending or Descending as required.  

6.1.3 Calculate summary information like: sum, 
minimum, maximum, average 

 Click Summary Options… in the Report Wizard 
window. 

 Select the Sum, Avg, Min, Max checkbox as 
required to include the calculations in the group 
footer.  

 Click OK. 

 Follow the steps until the final window of the Report 
Wizard.  

6.1.4 Edit a report: change arrangement of data fields, 
headings. 

 In Design View, click a data field or heading and 
drag to the required location. 

 In some cases, the data fields may need to cut to be 
later pasted back, or other data fields may need to 
be resized to make room for this move. 

6.1.5 Edit a report: add, modify text in headers, footers. 

 In Design View, click the text box in the header or 
footer.  

 Modify the text as required. 

6.1.6 Export a table, query output in spreadsheet, text 
file, csv, XML format to a location on a drive.  

 

 Select the object in the Navigation Pane. 

 On the External Data tab, in the Export group, click 
the relevant Application button.  

 Select a location.  

 Check the Export data with formatting and layout 
checkbox. 

 Click OK. 

6.1.7 Export a report output in pdf format to a location 
on a drive. 

 Click the report to be exported. 

 On the External Data tab, in the Export group, click 
PDF or XPS.  

 Navigate to the drive to save the report to.  

 Ensure PDF is selected in the Save as type: drop-
down menu, and click Publish. 

 In the Export – PDF window, decide whether to 
Save export steps or not. Click Close. 

6.2 Printing 

6.2.1 Change table, form, query output, report 
orientation: portrait, landscape. 

 

 Open the table, form, query output or report. 

 On the File tab, click Print. 

 Click Print Preview. 

 On the Print Preview tab, in the Page Layout group, 
click the Portrait or Landscape buttons.  

6.2.1 Change paper size. 

 

 On the File tab, click Print.  

 Click Print Preview. 

 On the Print Preview tab, in the Page Size group, 
click the Size button. 

 Click the size required.  

6.2.2 Print a page. 

 

 On the File tab, click Print. 

 Click Print. 

 Click OK. 

6.2.2 Print selected record(s). 

 Select the records to print. 

 On the File tab, click Print. 

 Click Print. 

 Check the Selected Record(s) checkbox. 

 Click OK. 

6.2.2 Print a complete table. 

 On the File tab, click Print. 

 Click Print. 

 Ensure the All check box is checked. 

 Click OK. 

6.2.3 Print all records, specific page(s) using form 
layout. 

 On the File tab, click Print. 

 Click Print. 

 To print all records, ensure the All checkbox is 
checked.  

 To print specific pages, check the Pages checkbox 
and enter the required number references in the 
From: and To: boxes. 

 Click OK. 

6.2.4 Print the result of a query. 

 On the File tab, click Print. 

 Click Print. 

 Click OK. 

6.2.5 Print specific page(s) in a report, print complete 
report. 

 On the File tab, click Print. 

 Click Print. 

 To print all pages, ensure the All check box is 
checked.  

 To print specific pages, check the Pages check box 
and enter the required number references in the 
From: and To: boxes. 

 Click OK. 
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